Click or drag to resize

IGH_PreviewData Interface

All IGH_Goo types that wish to participate in Viewport redraws must implement this interface.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_PreviewData

The IGH_PreviewData type exposes the following members.

Properties
  NameDescription
Public propertyClippingBox
Gets the clipping box for this data. The clipping box is typically the same as the boundingbox.
Top
Methods
  NameDescription
Public methodDrawViewportMeshes
Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called.
Public methodDrawViewportWires
Implement this function to draw all wire and point previews.
Top
See Also