Click or drag to resize

IGH_ValueProxy Interface

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_ValueProxy

The IGH_ValueProxy type exposes the following members.

Properties
  NameDescription
Public propertyIsParsable
Gets a value indicating whether or not the type can be instantiated from a String
Public propertyIsValid
Gets a value indicating whether or not the current value is valid
Public propertyProxyName
Gets a human-friendly name description of the template type
Public propertyProxyType
Gets the System.Type description of the template type
Public propertyProxyValue
Gets an instance of the local template type object
Public propertyUserString
Gets or sets the user-defined string that describes this proxy This only really makes sense if the Proxy is Parsable.
Top
Methods
  NameDescription
Public methodDuplicate
Create an exact duplicate of the type.
Public methodFromString
If IsParsable(), then attempts to convert the string to a generic type value
Public methodMutateString
Munge a string to remove obvious errors on account of the user.
Public methodToString
Returns a String description of the current value.
Top
See Also