GH_Boolean Class |
Namespace: Grasshopper.Kernel.Types
The GH_Boolean type exposes the following members.
Name | Description | |
---|---|---|
GH_Boolean |
Blank constructor
| |
GH_Boolean(Boolean) | Initializes a new instance of the GH_Boolean class | |
GH_Boolean(GH_Boolean) | Initializes a new instance of the GH_Boolean class |
Name | Description | |
---|---|---|
IsValid |
Gets the validity of this instance. Booleans are always valid.
TypeDescription | (Overrides GH_GooTTypeDescription.) | |
Name | Description | |
---|---|---|
CastFrom | (Overrides GH_GooTCastFrom(Object).) | |
Duplicate | (Overrides GH_GooTDuplicate.) | |
DuplicateBoolean | ||
EmitProxy | (Overrides GH_GooTEmitProxy.) | |
ToString | (Overrides GH_GooTToString.) | |
Write | (Overrides GH_GooTWrite(GH_IWriter).) |