Click or drag to resize

GH_Colour Class

Represents an ARGB colour. GH_Colour re-implements the framework System.Drawing.Color type.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooColor
    Grasshopper.Kernel.TypesGH_Colour

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Colour : GH_Goo<Color>

The GH_Colour type exposes the following members.

Constructors
  NameDescription
Public methodGH_Colour
Blank constructor
Public methodGH_Colour(Color)
Initializes a new instance of the GH_Colour class
Public methodGH_Colour(GH_Colour)
Initializes a new instance of the GH_Colour class
Top
Properties
  NameDescription
Public propertyIsValid
Gets the validity of this instance.
(Overrides GH_GooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate (Overrides GH_GooTDuplicate.)
Public methodDuplicateColour
Public methodEmitProxy (Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also