Click or drag to resize

GH_Integer Class

Represents a 32-bit signed integer. GH_Integer re-implements the framework System.Int32 type.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooInt32
    Grasshopper.Kernel.TypesGH_Integer

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Integer : GH_Goo<int>

The GH_Integer type exposes the following members.

Constructors
  NameDescription
Public methodGH_Integer
Blank constructor
Public methodGH_Integer(GH_Integer)
Initializes a new instance of the GH_Integer class
Public methodGH_Integer(Int32)
Initializes a new instance of the GH_Integer class
Top
Properties
Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate (Overrides GH_GooTDuplicate.)
Public methodDuplicateInteger
Public methodEmitProxy (Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also