GH_Matrix Class |
Namespace: Grasshopper.Kernel.Types
The GH_Matrix type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_Matrix |
Blank constructor
|
![]() | GH_Matrix(GH_Matrix) | Initializes a new instance of the GH_Matrix class |
![]() | GH_Matrix(Matrix) | Initializes a new instance of the GH_Matrix class |
Name | Description | |
---|---|---|
![]() | IsValid |
Gets the validity of this instance. Integers are always valid.
(Overrides GH_GooTIsValid.) |
![]() | IsValidWhyNot |
Gets a string describing the state of "invalidness".
If the instance is valid, then this property should return
Nothing or String.Empty.
(Inherited from GH_GooT.) |
![]() | TypeDescription | (Overrides GH_GooTTypeDescription.) |
![]() | TypeName | (Overrides GH_GooTTypeName.) |
![]() | Value |
Gets or sets the internal data.
(Inherited from GH_GooT.) |
Name | Description | |
---|---|---|
![]() | CastFrom | (Overrides GH_GooTCastFrom(Object).) |
![]() | CastToQ(Q) |
Attempt a cast to type Q.
(Inherited from GH_GooT.) |
![]() | CastToT(T) | (Overrides GH_GooTCastToQ(Q).) |
![]() ![]() | CloneMatrix |
Duplicates a Matrix.
|
![]() | Duplicate | (Overrides GH_GooTDuplicate.) |
![]() | DuplicateMatrix | |
![]() | EmitProxy |
Create a new proxy for this instance. Return Null if this class does not support proxies.
(Inherited from GH_GooT.) |
![]() | Read | (Overrides GH_GooTRead(GH_IReader).) |
![]() | ScriptVariable | (Overrides GH_GooTScriptVariable.) |
![]() | ToString | (Overrides GH_GooTToString.) |
![]() | Write | (Overrides GH_GooTWrite(GH_IWriter).) |