GH_Vector Class |
Namespace: Grasshopper.Kernel.Types
The GH_Vector type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_Vector |
Default constructor. Creates a zero-length vector.
|
![]() | GH_Vector(GH_Vector) |
Create a duplicate of another vector
|
![]() | GH_Vector(Vector3d) |
Create a vector from x, y and z components.
|
Name | Description | |
---|---|---|
![]() | IsValid | (Overrides GH_GooTIsValid.) |
![]() | IsValidWhyNot |
Gets a string describing the state of "invalidness".
If the instance is valid, then this property should return
Nothing or String.Empty.
(Inherited from GH_GooT.) |
![]() | TypeDescription | (Overrides GH_GooTTypeDescription.) |
![]() | TypeName | (Overrides GH_GooTTypeName.) |
![]() | Value |
Gets or sets the internal data.
(Inherited from GH_GooT.) |
Name | Description | |
---|---|---|
![]() | CastFrom |
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GooTCastFrom(Object).) |
![]() | CastToQ(Q) |
Attempt a cast to type Q.
(Inherited from GH_GooT.) |
![]() | CastToT(T) |
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GooTCastToQ(Q).) |
![]() | Duplicate |
Create a duplicate of this vector.
(Overrides GH_GooTDuplicate.) |
![]() | DuplicateVector |
Create a duplicate of this vector.
|
![]() | EmitProxy |
Returns a proxy that represents this vector. Do not call this function unless you're
(Overrides GH_GooTEmitProxy.) |
![]() | Read | (Overrides GH_GooTRead(GH_IReader).) |
![]() | ScriptVariable |
This function will be called when the local IGH_Goo instance
disappears into a user Script. This would be an excellent place to
cast your IGH_Goo type to a simple data type.
(Inherited from GH_GooT.) |
![]() | ToString |
Format the vector using default grasshopper formatting logic.
(Overrides GH_GooTToString.) |
![]() | Write | (Overrides GH_GooTWrite(GH_IWriter).) |