GH_UndoRecord Class |
Namespace: Grasshopper.Kernel.Undo
The GH_UndoRecord type exposes the following members.
Name | Description | |
---|---|---|
GH_UndoRecord | Initializes a new instance of the GH_UndoRecord class | |
GH_UndoRecord(String) | Initializes a new instance of the GH_UndoRecord class | |
GH_UndoRecord(String, IGH_UndoAction) | Initializes a new instance of the GH_UndoRecord class | |
GH_UndoRecord(String, IGH_UndoAction) | Initializes a new instance of the GH_UndoRecord class | |
GH_UndoRecord(String, IEnumerableIGH_UndoAction) | Initializes a new instance of the GH_UndoRecord class |
Name | Description | |
---|---|---|
ActionCount |
Gets the number of actions stored in this record.
| |
Actions |
Gets or sets the actions inside this record.
| |
ExpiresDisplay |
Gets the display expiration flag for this event. If True, the Rhino viewports will be redrawn
once the entire undo record has been completed.
If ExpiresSolution is set to true, ExpriresDisplay is implied.
| |
ExpiresSolution |
Gets the solution expiration flag for this event.
If True, the solution needs to be recalculated once the entire undo record has been completed.
| |
Guid |
Gets the ID of this undo item. Every undo record has a unique ID.
| |
Name |
Gets or sets the name of the undo record (as displayed in the menu)
| |
State |
Gets the undo state of this record. The state dictates which action are legal.
| |
Time |
Gets the time at which this record was created.
|
Name | Description | |
---|---|---|
AddAction |
Append an undo action to this record. You should only do this prior to calling undo for the first time.
| |
Redo | ||
Undo |