ModelAnnotationStyle Class |
Namespace: Grasshopper.Rhinoceros.Annotations
The ModelAnnotationStyle type exposes the following members.
Name | Description | |
---|---|---|
ModelAnnotationStyle | Initializes a new instance of the ModelAnnotationStyle class | |
ModelAnnotationStyle(ModelAnnotationStyleAttributes) | Initializes a new instance of the ModelAnnotationStyle class | |
ModelAnnotationStyle(DimensionStyle) | Initializes a new instance of the ModelAnnotationStyle class | |
ModelAnnotationStyle(Guid) | Initializes a new instance of the ModelAnnotationStyle class |
Name | Description | |
---|---|---|
ArrowSettings | ||
DimensionScale | ||
DimensionSettings | ||
LeaderSettings | ||
TextSettings | ||
ToleranceSettings | ||
UnitsSettings | ||
Unset | ||
Name | Description | |
---|---|---|
Cast | ||
CastToT(T) | (Overrides ModelContentCastToT(T).) | |
ToAttributes | ||
Name | Description | |
---|---|---|
(ModelAnnotationStyleAttributes to ModelAnnotationStyle) | ||
(DimensionStyle to ModelAnnotationStyle) | ||
(String to ModelAnnotationStyle) |