Click or drag to resize

ModelStandardViewport Class

Represents a Rhino standard modeling viewport. Wraps the main viewport of a modeling RhinoView instance.
Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros.Display
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class ModelStandardViewport : ModelViewport

The ModelStandardViewport type exposes the following members.

Constructors
  NameDescription
Public methodModelStandardViewport
Initializes a new instance of the ModelStandardViewport class
Public methodModelStandardViewport(ModelStandardViewportAttributes)
Initializes a new instance of the ModelStandardViewport class
Public methodModelStandardViewport(Guid)
Initializes a new instance of the ModelStandardViewport class
Public methodModelStandardViewport(RhinoViewport)
Initializes a new instance of the ModelStandardViewport class
Top
Properties
Methods
  NameDescription
Public methodStatic memberCast
Public methodCastToT(T) (Overrides ModelViewportCastToT(T).)
Public methodToAttributes
Top
Operators
See Also