Click or drag to resize

ModelLineWidth Class

Represents a Rhino model linetype.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooDouble
    Grasshopper.Kernel.TypesGH_Number
      Grasshopper.Rhinoceros.DraftingModelLineWidth

Namespace:  Grasshopper.Rhinoceros.Drafting
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class ModelLineWidth : GH_Number, 
	IEquatable<ModelLineWidth>

The ModelLineWidth type exposes the following members.

Constructors
  NameDescription
Public methodModelLineWidth
Initializes a new instance of the ModelLineWidth class
Public methodModelLineWidth(Double)
Initializes a new instance of the ModelLineWidth class
Top
Properties
  NameDescription
Public propertyTypeDescription (Overrides GH_NumberTypeDescription.)
Public propertyTypeName (Overrides GH_NumberTypeName.)
Top
Methods
  NameDescription
Public methodCastFrom (Overrides GH_NumberCastFrom(Object).)
Public methodDuplicate (Overrides GH_NumberDuplicate.)
Public methodEquals(ModelLineWidth)
Public methodEquals(Object) (Overrides ObjectEquals(Object).)
Public methodGetHashCode (Overrides ObjectGetHashCode.)
Public methodToString (Overrides GH_NumberToString.)
Top
See Also