Click or drag to resize

GH_Number Class

Represents a double-precision floating point number. GH_Number re-implements the framework System.Double type.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooDouble
    Grasshopper.Kernel.TypesGH_Number
      Grasshopper.Rhinoceros.DraftingModelLineWidth

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Number : GH_Goo<double>

The GH_Number type exposes the following members.

Constructors
  NameDescription
Public methodGH_Number
Blank constructor
Public methodGH_Number(Double)
Initializes a new instance of the GH_Number class
Public methodGH_Number(GH_Number)
Initializes a new instance of the GH_Number class
Top
Properties
  NameDescription
Public propertyIsValid
Gets the validity of this instance. If the number is NaN, then it is considered invalid
(Overrides GH_GooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate (Overrides GH_GooTDuplicate.)
Public methodDuplicateNumber
Public methodEmitProxy (Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also