Click or drag to resize

ModelLinetype Class

Represents a Rhino model linetype. Wraps the functionality of the Linetype type.
Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros.Drafting
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class ModelLinetype : ModelComponentContent, 
	IGH_BakeAwareData

The ModelLinetype type exposes the following members.

Constructors
  NameDescription
Public methodModelLinetype
Initializes a new instance of the ModelLinetype class
Public methodModelLinetype(ModelLinetypeAttributes)
Initializes a new instance of the ModelLinetype class
Public methodModelLinetype(Guid)
Initializes a new instance of the ModelLinetype class
Public methodModelLinetype(Linetype)
Initializes a new instance of the ModelLinetype class
Top
Properties
  NameDescription
Public propertyCapStyle
Public propertyJoinStyle
Public propertySegments
Public propertyTaperPoints
Public propertyStatic memberUnset
Public propertyWidth
Public propertyWidthUnits
Top
Methods
Operators
See Also