Description:

Inserts bitmap into Rhino's texture manager and returns a FileReference.

Syntax:
public static FileReference BitmapAsTextureFileReference(
this Bitmap bitmap,
uint crc
)
Parameters:
  • bitmap
  • Type: System.Drawing.Bitmap
  • The bitmap which will be referenced by the FileReference.
  • crc
  • Type: uint
  • The crc of the bitmap. This should be a unique number which changes if the contents of the bitmap changes. NOTE: if a different bitmap is provided using the same crc as a previous bitmap, then the previous bitmap will be overwritten in the texture manager and both previously returned FileReferences will reference the newly provided bitmap.
Returns:
Available since:
7.7

/
/
/
BitmapAsTextureFileReference

BitmapAsTextureFileReference method

Class:  Rhino.BitmapExtensions

Nothing found