Description:

Use this function to convert a System.Drawing.Bitmap from a bump to a normal texture

Syntax:
public static Bitmap ConvertToNormalMap(
this Bitmap bitmap,
bool bLossyCompressionSource,
out bool bPositiveZComponent
)
Parameters:
  • bitmap
  • Type: System.Drawing.Bitmap
  • bLossyCompressionSource
  • Type: bool
  • True if the source of the bitmap is an image with lossy compression (e.g. jpg). False otherwise. The check will be less strict if the image can contain errors due to lossy compression.
  • bPositiveZComponent
  • Type: bool
  • True if the image is a normal map with the z-component mapped to the range 0 .. +1. False if the image is a normal map with the z-component mapped to the range -1 .. +1.
Returns:
Type: Bitmap
Available since:
7.5

/
/
/
ConvertToNormalMap

ConvertToNormalMap method

Class:  Rhino.BitmapExtensions

Nothing found