Description:

Call this method to see if the DIB appears to be a normal map.

Syntax:
public static bool IsNormalMap(
this Bitmap bitmap,
bool bLossyCompressionSource,
out bool bPositiveZComponent
)
Parameters:
  • bitmap
  • Type: System.Drawing.Bitmap
  • bLossyCompressionSource
  • Type: bool
  • True if the source of the bitmap is an image with lossy compression (e.g. jpg). False otherwise. The check will be less strict if the image can contain errors due to lossy compression.
  • bPositiveZComponent
  • Type: bool
  • True if the image is a normal map with the z-component mapped to the range 0 .. +1. False if the image is a normal map with the z-component mapped to the range -1 .. +1.
Returns:
Type: bool
Returns True if the bitmap appears to be a normal map. False otherwise.
Available since:
7.5

IsNormalMap method

Class:  Rhino.BitmapExtensions

Nothing found