Description:
Build custom render mesh(es) for this object.
Syntax:
deprecated in 6.0
obsolete: This version is obsolete because it returns the obsolete RenderPrimitiveList - ie, the old school custom render meshes. Use CustomRenderMeshes instead.
Parameters:
- viewport
- Type: ViewportInfo
- The viewport being rendered.
- preview
- Type: bool
- Type of mesh to build, if preview is True then a smaller mesh may be generated in less time, False is meant when actually rendering.
Returns:
Type: RenderPrimitiveList
Returns a RenderPrimitiveList if successful otherwise returns null.
Available since:
5.7
Description:
Build custom render mesh(es) for this object.
Syntax:
public RenderPrimitiveList GetRenderPrimitiveList(
ViewportInfo viewport,
DisplayPipelineAttributes attrs
)
ViewportInfo viewport,
DisplayPipelineAttributes attrs
)
deprecated in 8.0
Parameters:
- viewport
- Type: ViewportInfo
- The viewport being rendered.
- attrs
- Type: Rhino.Display.DisplayPipelineAttributes
- Attributes for the view mode you are supplying meshes for. Will be None if this is a modal rendering.
Returns:
Type: RenderPrimitiveList
Returns a RenderPrimitiveList if successful otherwise returns null.
Available since:
6.0