Description:

Reports if a sub-object can be selected.

Syntax:
public bool IsSubObjectSelectable(
ComponentIndex componentIndex,
bool ignoreSelectionState
)
Parameters:
  • ignoreSelectionState
  • Type: bool
  • If true, then selected objects are selectable. If false, then selected objects are not selectable.
Returns:
Type: bool
True if the specified sub-object can be selected.
Remarks:
Objects that are locked, hidden, or on locked or hidden layers cannot be selected. If IsSelectableWithGripsOn() returns false, then that object is not selectable if it has grips turned on.
Available since:
5.0

/
/
/
IsSubObjectSelectable

IsSubObjectSelectable method

Class:  Rhino.DocObjects.RhinoObject

Nothing found