Description:

Add a new layer to the model.

Syntax:
public int AddLayer(
string name,
Color color,
Guid parentId
)
Parameters:
  • color
  • Type: System.Drawing.Color
  • Layer color.
  • parentId
  • Type: System.Guid
  • The id of the parent layer, can be Guid.Empty.
Returns:
Type: int
The layer's index (>=0) is returned. Otherwise, RhinoMath.UnsetIntIndex is returned.
Available since:
7.30

Description:

Easy way to add a new layer to the model.

Syntax:
public int AddLayer(
string name,
Color color
)
Parameters:
  • color
  • Type: System.Drawing.Color
  • Layer color.
Returns:
Type: int
The layer's index (>=0) is returned. Otherwise, RhinoMath.UnsetIntIndex is returned.
Remarks:
Note, the layer name will be modified as needed in the model and manifest.
Available since:
7.6

Nothing found