Description:

Intersects two Breps.

Syntax:
public static bool BrepBrep(
Brep brepA,
Brep brepB,
double tolerance,
bool joinCurves,
out Curve[] intersectionCurves,
out Point3d[] intersectionPoints
)
Parameters:
  • brepA
  • Type: Brep
  • First Brep for intersection.
  • brepB
  • Type: Brep
  • Second Brep for intersection.
  • tolerance
  • Type: double
  • Intersection tolerance.
  • joinCurves
  • Type: bool
  • If true, join the resulting curves where possible.
  • intersectionCurves
  • Type: Curve[]
  • The intersection curves will be returned here.
  • intersectionPoints
  • Type: Point3d[]
  • The intersection points will be returned here.
Returns:
Type: bool
True on success; False on failure.
Available since:
8.12

Description:

Intersects two Breps.

Syntax:
public static bool BrepBrep(
Brep brepA,
Brep brepB,
double tolerance,
out Curve[] intersectionCurves,
out Point3d[] intersectionPoints
)
Parameters:
  • brepA
  • Type: Brep
  • First Brep for intersection.
  • brepB
  • Type: Brep
  • Second Brep for intersection.
  • tolerance
  • Type: double
  • Intersection tolerance.
  • intersectionCurves
  • Type: Curve[]
  • The intersection curves will be returned here.
  • intersectionPoints
  • Type: Point3d[]
  • The intersection points will be returned here.
Returns:
Type: bool
True on success; False on failure.
Available since:
5.0

Nothing found