Description:
Intersects a mesh with a collection of infinite planes.
Syntax:
Parameters:
- mesh
- Type: Mesh
- Mesh to intersect.
- planes
- Type: IEnumerable<Plane>
- Planes to intersect with.
Returns:
Type: Polyline[]
An array of polylines describing the intersection loops, or None if no intersections could be found.
Available since:
5.0
Description:
Intersects a mesh with a collection of infinite planes.
Syntax:
public static Polyline[] MeshPlane(
Mesh mesh,
MeshIntersectionCache cache,
IEnumerable<Plane> planes,
double tolerance
)
Mesh mesh,
MeshIntersectionCache cache,
IEnumerable<Plane> planes,
double tolerance
)
Parameters:
- mesh
- Type: Mesh
- Mesh to intersect.
- cache
- Type: MeshIntersectionCache
- Intersection cache for the mesh.
- planes
- Type: IEnumerable<Plane>
- Planes to intersect with.
- tolerance
- Type: double
- Intersection tolerance.
Returns:
Type: Polyline[]
An array of polylines describing the intersection loops, or None if no intersections could be found.
Available since:
8.0
Description:
Intersects a mesh with an infinite plane.
Syntax:
public static Polyline[] MeshPlane(
Mesh mesh,
MeshIntersectionCache cache,
Plane plane,
double tolerance
)
Mesh mesh,
MeshIntersectionCache cache,
Plane plane,
double tolerance
)
Parameters:
- mesh
- Type: Mesh
- Mesh to intersect.
- cache
- Type: MeshIntersectionCache
- Intersection cache for mesh.
- plane
- Type: Plane
- Plane to intersect with.
- tolerance
- Type: double
- Intersection tolerance.
Returns:
Type: Polyline[]
An array of polylines describing the intersection loops, or None if no intersections could be found.
Available since:
8.0
Description:
Intersects a mesh with an infinite plane.
Syntax:
Parameters:
- mesh
- Type: Mesh
- Mesh to intersect.
- plane
- Type: Plane
- Plane to intersect with.
Returns:
Type: Polyline[]
An array of polylines describing the intersection loops, or None if no intersections could be found.
Available since:
5.0