Description:
Finds all of the mesh faces on each of two Rhino objects that interfere within a clash distance. This function uses the object's mesh to calculate the interferences. Acceptable object types include: BrepObject, ExtrusionObject, MeshObject, and SubDObject.
Syntax:
public static Mesh[] FindDetail(
RhinoObject objA,
RhinoObject objB,
double distance,
MeshType meshType,
MeshingParameters meshingParameters
)
RhinoObject objA,
RhinoObject objB,
double distance,
MeshType meshType,
MeshingParameters meshingParameters
)
Parameters:
- objA
- Type: RhinoObject
- The first Rhino object.
- objB
- Type: RhinoObject
- The second Rhino object.
- distance
- Type: double
- The largest distance at which a clash can occur.
- meshType
- Type: MeshType
- The type of mesh to be used for the calculation.
- meshingParameters
- Type: MeshingParameters
- The meshing parameters used to generate meshes for the calculation.
Returns:
Type: Mesh[]
The resulting meshes are sub-meshes of the input meshes if successful, or an empty array on error.
Available since:
7.0
Description:
Finds all of the mesh faces on each of two Rhino objects that interfere within a clash distance. This function uses the object's mesh to calculate the interferences. Acceptable object types include: BrepObject, ExtrusionObject, MeshObject, and SubDObject.
Syntax:
Parameters:
- objA
- Type: RhinoObject
- The first Rhino object.
- objB
- Type: RhinoObject
- The second Rhino object.
- distance
- Type: double
- The largest distance at which a clash can occur.
Returns:
Type: Mesh[]
The resulting meshes are sub-meshes of the input meshes if successful, or an empty array on error.
Available since:
7.0