Description:

Searches for locations where the distance froma mesh in one setof meshes is less than distance toanother mesh in a second setof meshes.

Syntax:
public static MeshClash[] Search(
IEnumerable<Mesh> setA,
IEnumerable<Mesh> setB,
double distance,
int maxEventCount
)
Parameters:
  • setA
  • Type: IEnumerable<Mesh>
  • The first set of meshes.
  • setB
  • Type: IEnumerable<Mesh>
  • The second set of meshes.
  • distance
  • Type: double
  • The largest distance at which there is a clash. All values smaller than this cause a clash as well.
  • maxEventCount
  • Type: int
  • The maximum number of clash objects.
Returns:
An array of clash objects.
Available since:
5.0

Description:

Searches for locations where the distance from a RhinoObject, in one set of objects, is less than the specified distance to another RhinoObject in a second set of objects. This function uses the object's mesh to calculate the interferences. Acceptable object types include: BrepObject, ExtrusionObject, MeshObject, and SubDObject.

Syntax:
public static MeshInterference[] Search(
IEnumerable<RhinoObject> setA,
IEnumerable<RhinoObject> setB,
double distance,
MeshType meshType,
MeshingParameters meshingParameters
)
Parameters:
  • setA
  • Type: IEnumerable<RhinoObject>
  • The first set of Rhino objects.
  • setB
  • Type: IEnumerable<RhinoObject>
  • The second set of Rhino objects.
  • distance
  • Type: double
  • The largest distance at which a clash can occur.
  • meshType
  • Type: MeshType
  • The type of mesh to be used for the calculation.
  • meshingParameters
  • Type: MeshingParameters
  • The meshing parameters used to generate meshes for the calculation.
Returns:
An array of mesh interference object if successful, or an empty array on failure.
Available since:
7.0

Description:

Searches for locations where the distance from a RhinoObject, in one set of objects, is less than the specified distance to another RhinoObject in a second set of objects. This function uses the object's mesh to calculate the interferences. Acceptable object types include: BrepObject, ExtrusionObject, MeshObject, and SubDObject.

Syntax:
public static MeshInterference[] Search(
IEnumerable<RhinoObject> setA,
IEnumerable<RhinoObject> setB,
double distance
)
Parameters:
  • setA
  • Type: IEnumerable<RhinoObject>
  • The first set of Rhino objects.
  • setB
  • Type: IEnumerable<RhinoObject>
  • The second set of Rhino objects.
  • distance
  • Type: double
  • The largest distance at which a clash can occur.
Returns:
An array of mesh interference object if successful, or an empty array on failure.
Available since:
7.0

Description:

Searches the locations where the distance fromthe first meshtoa mesh in the second setof meshes is less than the provided value.

Syntax:
public static MeshClash[] Search(
Mesh meshA,
IEnumerable<Mesh> setB,
double distance,
int maxEventCount
)
Parameters:
  • meshA
  • Type: Mesh
  • The first mesh.
  • setB
  • Type: IEnumerable<Mesh>
  • The second set of meshes.
  • distance
  • Type: double
  • The largest distance at which there is a clash. All values smaller than this cause a clash as well.
  • maxEventCount
  • Type: int
  • The maximum number of clash objects.
Returns:
An array of clash objects.
Available since:
5.0

Description:

Searches the locations where the distance fromthe first meshtothe second mesh is less than the provided value.

Syntax:
public static MeshClash[] Search(
Mesh meshA,
Mesh meshB,
double distance,
int maxEventCount
)
Parameters:
  • meshA
  • Type: Mesh
  • The first mesh.
  • meshB
  • Type: Mesh
  • The second mesh.
  • distance
  • Type: double
  • The largest distance at which there is a clash. All values smaller than this cause a clash as well.
  • maxEventCount
  • Type: int
  • The maximum number of clash objects.
Returns:
An array of clash objects.
Available since:
5.0

Nothing found