DimStyleLengthFactor

Returns or changes the length factor of a dimension style. Length factor is the conversion factor between Rhino units and dimension units.

Syntax

Rhino.DimStyleLengthFactor (strDimStyle [, dblFactor])

Parameters

strDimStyle

Required.  String.  The name of an existing dimension style.

dblFactor

Optional.  Number.  The new length factor.  If omitted, the current length factor is returned.

Returns

Number

If dblFactor is not specified, the current length factor if successful.

Number

If dblFactor is specified, the previous length factor if successful.

Null

If not successful, or on error.

Example

Dim strDimStyle, dblSize

strDimStyle = Rhino.CurrentDimStyle

dblFactor = Rhino.DimStyleLengthFactor(strDimStyle)

If dblFactor > 1.0 Then

Rhino.DimStyleLengthFactor strDimStyle, 1.0

End If

Also See

DimStylePrefix

DimStyleSuffix