DimStylePrefix

Returns or changes the prefix of a dimension style - the text to prefix to the dimension text.

Syntax

Rhino.DimStylePrefix (strDimStyle [, strPrefix])

Parameters

strDimStyle

Required.  String.  The name of an existing dimension style.

strPrefix

Optional.  String.  The new prefix.  If omitted, the current prefix is returned.  To remove the prefix, pass in an empty string, or "".

Returns

String

If strPrefix is not specified, the current prefix if successful.  Note, if no current prefix exists, Null is returned.

String

If strPrefix is specified, the previous prefix if successful.  Note, if no previous prefix exists, Null is returned.

Null

If not successful, or on error.

Example

Dim strDimStyle

strDimStyle = Rhino.CurrentDimStyle

Rhino.DimStylePrefix strDimStyle, "["

Also See

DimStyleLengthFactor

DimStyleSuffix