IsLayerState

Verifies the existence of a layer state in the document.

Syntax

Rhino.IsLayerState (strState)

Parameters

strState

Required.  String.  The name of an existing layer state.

Returns

True

If successful.

False

If not successful.

Null

On error.

Example

Sub TestIsLayerState

  Dim objPlugIn

  On Error Resume Next

  Set objPlugIn = Rhino.GetPluginObject("Rhino Bonus Tools")

  If Err Then

    MsgBox Err.Description

    Exit Sub

  End If

  MsgBox objPlugIn.IsLayerState("MyLayerState")

End Sub

Also See

LayerStateCount

LayerStateNames