Rhino's LayerStateManager command allows you to save the states of layers and restore them at a later time. The command is implemented in the Rhino Bonus Tools plug-in, or RhinoBonusTools.rhp. Because the LayerStateManager command resides in a plug-in, you will first need to get the plug-in's scriptable object, using GetPlugInObject, before you can call any of these methods.
For example:
Sub TestLayerStates
Dim objPlugIn
On Error Resume Next
Set objPlugIn = Rhino.GetPluginObject("Rhino Bonus Tools")
If Err Then
MsgBox Err.Description
Exit Sub
End If
'TODO: call a layer state method...
End Sub
Method |
Description |
Deletes a layer state. |
|
Exports layer states to a file. |
|
Import layer states from a file. |
|
Verifies that a layer state exists. |
|
Returns the number of layer states. |
|
Returns layer state names. |
|
Renames a layer state. |
|
Restores a saved layer state. |
|
Saves a layer state. |