IsLight

Verifies an object is a light object.

Syntax

Rhino.IsLight (strObject)

Parameters

strObject

Required.  String.  The light object's identifier.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select a light")

If Rhino.IsLight(strObject) Then

Rhino.Print "The object is a light."

Else

Rhino.Print "The object is not a light."

End If

Also See

EnableLight

IsLightEnabled

LightColor

LightCount

LightName

LightObjects