Returns or changes the color of a light. Light colors are represented as RGB colors. An RGB color specifies the relative intensity of red, green, and blue to cause a specific color to be displayed.
Rhino.LightColor (strObject [, lngColor])
strObject |
Required. String. The light object's identifier. |
lngColor |
Optional. Number. The new color value. If omitted, the current light color is returned. |
Number |
If a color value is not specified, the current light value if successful. |
Number |
If a color value is specified, the previous light value if successful. |
Null |
If not successful, or on error. |
Const rhObjectLight = 256
Dim strObject
strObject = Rhino.GetObject("Select a light", rhObjectLight)
If Not IsNull(strObject) Then
Rhino.LightColor strObject, RGB(0, 250, 255)
End If