Returns or modifies the user-definable name of a light object.
Rhino.LightName (strObject [, strName])
strObject |
Required. String. The identifier of the light object. |
strName |
Optional. String. The new light name. If omitted, the current light name is returned. |
String |
If strName is not specified, the current light name if successful. |
String |
If strName is specified, the previous light name if successful. |
Null |
If not successful, or on error. |
Const rhObjectLight = 256
Dim strObject, strName
strObject = Rhino.GetObject("Select a light", rhObjectLight)
If Not IsNull(strObject) Then
strName = Rhino.GetString("New light name")
If Not IsNull(strName) Then
Rhino.LightName strObject, strName
End If
End If