Returns or modifies a material's environment bitmap filename.
Rhino.MaterialEnvironmentMap (intMaterialIndex [, strFileName])
intMaterialIndex |
Required. Number. The zero-based source material index. |
strFileName |
Optional. String. The environment bitmap filename. |
String |
If strFileName is not specified, the current environment bitmap filename if successful. |
String |
If strFileName is specified, the previous environment bitmap filename if successful. |
Null |
It not successful, or on error. |
Dim strObject, intIndex
strObject = Rhino.GetObject("Select object")
If Not IsNull(strObject) Then
intIndex = Rhino.ObjectMaterialIndex(strObject)
If (intIndex > -1) Then
Rhino.MaterialEnvironmentMap intIndex, "C:\Windows\Coffee Bean.bmp"
End If
End If