MaterialTransparencyMap

Returns or modifies a material's transparency bitmap filename.

Syntax

Rhino.MaterialTransparencyMap (intMaterialIndex [, strFileName])

Parameters

intMaterialIndex

Required.  Number.  The zero-based source material index.

strFileName

Optional.  String.  The transparency bitmap filename.

Returns

String

If strFileName is not specified, the current transparency bitmap filename if successful.

String

If strFileName is specified, the previous transparency bitmap filename if successful.

Null

It not successful, or on error.

Example

Dim strObject, intIndex

strObject = Rhino.GetObject("Select object")

If Not IsNull(strObject) Then

intIndex = Rhino.ObjectMaterialIndex(strObject)

If (intIndex > -1) Then

Rhino.MaterialTransparencyMap intIndex, "C:\Windows\Coffee Bean.bmp"

End If

End If

Also See

MaterialBump

MaterialEnvironmentMap

MaterialTexture