MeshToNurb

Duplicates each polygon in a polygon mesh with a NURBS surface. The resulting surfaces are then joined into a polysurface and added to the document. Note, disjoint meshes will be split into unconnected pieces before surface creation.

Note: Complex meshes will create NURBS surfaces that use large amounts of memory. For more information, see the Rhino help file for information on the MeshToNURB command.

Warning: This method converts each polygon face to a NURBS surface. It is not meant to convert entire mesh models to NURBS models and there is, in fact, no simple way to accomplish this.

Syntax

Rhino.MeshToNurb (strObject [, blnTrimmedTriangles [, blnDelete]])

Parameters

strObject

Required.  String.  The identifier of a mesh object.

blnTrimmedTriangles

Optional.  Boolean.  If True (default), triangles in the mesh will be represented by trimmed planes.  If False, triangles in the mesh will be represented by untrimmed singular bilinear NURBS surfaces (have two of the control points collapsed into a singularity).

blnDelete

Optional.  Boolean.  Delete input object.  The default is not to delete objects (False).

Returns

Array

An array of strings identifying the newly created objects if successful.

Null

If not successful, or on error.

Example

Const rhObjectMesh = 32

Dim strObject

strObject = Rhino.GetObject("Select mesh", rhObjectMesh)

If Not IsNull(strObject) Then

  Call Rhino.MeshToNurb(strObject)

End If

Also See

IsMesh

MeshFaces

MeshVertices