Home > RhinoScript Methods > Object Grip Methods
Rhino allows the user to point edit curves, surfaces, and polygon meshes. Such points are controlled by objects called grips. Individual grips are accessed by specifying an zero-based index value. Note, before an object's grips can be queried or manipulated, they must be enabled. The following methods are available for querying or manipulating Rhino grip objects.
Method |
Description |
Enables or disables an object's editing grips. |
|
Prompts the user to pick a single object grip. |
|
Prompts the user to pick one or more grips from one or more objects. |
|
Returns the index of the next grip of an object. |
|
Returns the number of grips owned by an object. |
|
Returns or modifies the location of an object's grip. |
|
Returns or modifies the location of all grips owned by an object. |
|
Returns the identifier of object that owns a grip object. |
|
Verifies that an object's grips are turned on and visible. |
|
Verifies that at least one object grip is selected. |
|
Returns the index of the previous grip of an object. |
|
Returns the indices of the selected grips of an object. |
|
Selects an object's grip. |
|
Selects all grips owned by an object. |
|
Unselects an object's grip. |
|
Unselects all grips owned by an object. |