Returns the definition of a torus surface.
Rhino.SurfaceTorus (strSurface)
strSurface |
Required. String. The surface object's identifier. |
Array |
An array containing the definition of the torus if successful. The elements of the array are as follows:
|
||||||||||||
Null |
If not successful, or on error. |
Dim strTorus, arrTorus
strTorus = Rhino.AddTorus(Rhino.WorldXYPlane, 6, 2)
If Rhino.IsTorus(strTorus) Then
arrTorus = Rhino.SurfaceTorus(strTorus)
Rhino.AddTorus arrTorus(0), arrTorus(1), arrTorus(2)
End If