Click or drag to resize

GH_GDI_UtilFilletBoxOutline Method

Fillet all the corners of the combined outline of a set of rectangles.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GraphicsPath FilletBoxOutline(
	IEnumerable<Rectangle> boxes,
	int radius
)

Parameters

boxes
Type: System.Collections.GenericIEnumerableRectangle
Rectangles to outline.
radius
Type: SystemInt32
Radius of corner fillets.

Return Value

Type: GraphicsPath
GraphicsPath describing the filleted outline or null on failure.
See Also