Click or drag to resize

GH_GDI_UtilFilletRectangle Method

Create a rectangle with filleted corners.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GraphicsPath FilletRectangle(
	Rectangle box,
	int radius
)

Parameters

box
Type: System.DrawingRectangle
Rectangle to fillet.
radius
Type: SystemInt32
Fillet radius, radius will be limited if too large.

Return Value

Type: GraphicsPath
GraphicsPath describing filletted rectangle.
See Also