Click or drag to resize

GH_GDI_UtilSimplifyBoxes Method

Create a simplified collection of Rectangles that describe the same union space as the supplied rectangles.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static Rectangle[] SimplifyBoxes(
	IEnumerable<Rectangle> boxes
)

Parameters

boxes
Type: System.Collections.GenericIEnumerableRectangle
Rectangles to simplify.

Return Value

Type: Rectangle
An ordered collection of non-intersecting rectangles or null on failure.
See Also