Click or drag to resize

GH_ColourPickerBase Methods

The GH_ColourPickerBase type exposes the following members.

Methods
  NameDescription
Public methodInvalidate
Raise the Invalidated event.
Public methodMouseClick
Respond to mouse-click events.
Public methodMouseDoubleClick
Respond to mouse-doubleclick events.
Public methodMouseDown
Respond to mouse-down events.
Public methodMouseMove
Respond to mouse-move events.
Public methodMouseUp
Respond to mouse-up events.
Public methodOnColorChanged
Raise the ColorChanged event.
Public methodRender
Render this slider into a Graphics context.
Public methodRespondToEnter
Public methodRespondToEscape
Public methodSetUiScaling
Public methodSetupColourPicker(Color, Point4d, GH_ColourSpace)
Setup all UI elements.
Public methodSetupColourPicker(Color, Color, GH_ColourSpace)
Setup all UI elements.
Top
See Also