Click or drag to resize

GH_Plane Methods

The GH_Plane type exposes the following members.

Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).)
Public methodStatic memberDrawPlane(DisplayPipeline, Plane)
Draw a plane with default colours and default size.
Public methodStatic memberDrawPlane(DisplayPipeline, Plane, Double, Int32)
Public methodStatic memberDrawPlane(DisplayPipeline, Plane, Double, Int32, Color, Color, Color)
Public methodStatic memberDrawPlane(DisplayPipeline, Plane, Double, Int32, Color, Color, Color, Color)
Public methodStatic memberDrawPlaneIcon
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateGeometry
Create a duplicate of this plane.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodDuplicatePlane
Create a duplicate of this plane.
Public methodEmitProxy
Returns a proxy that represents this plane. Do not call this function unless you're
(Overrides GH_GeometricGooTEmitProxy.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry(RhinoDoc) (Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString
Format the plane using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
See Also