Rhino C++ API
8.13
|
SDK header stuff. More...
#include <rhinoSdkGetPolygon.h>
Public Attributes | |
int | m_NumSides |
variables More... | |
SDK header stuff.
CLASS CArgsRhinoGetPolygon
OVERVIEW TEXT Arguments for RhinoGetPolygon... functions
KEYWORDS
CArgsRhinoGetPolygon::CArgsRhinoGetPolygon | ( | ) |
CArgsRhinoGetPolygon::~CArgsRhinoGetPolygon | ( | ) |
CArgsRhinoGetPolygon::CArgsRhinoGetPolygon | ( | const CArgsRhinoGetPolygon & | ) |
const BOOL32 CArgsRhinoGetPolygon::AroundCurve | ( | ) | const |
const ON_Circle& CArgsRhinoGetPolygon::Circle | ( | ) | const |
const ON_wString& CArgsRhinoGetPolygon::CircumscribedAroundCurveCenterPrompt | ( | ) | const |
const ON_wString& CArgsRhinoGetPolygon::CircumscribedCenterPrompt | ( | ) | const |
const ON_wString& CArgsRhinoGetPolygon::CornerPrompt | ( | ) | const |
const ON_Curve* CArgsRhinoGetPolygon::Curve | ( | ) | const |
const ON_wString& CArgsRhinoGetPolygon::EdgeEndPrompt | ( | ) | const |
const ON_wString& CArgsRhinoGetPolygon::EdgeMidpointPrompt | ( | ) | const |
const BOOL32 CArgsRhinoGetPolygon::EdgeMode | ( | ) | const |
const ON_wString& CArgsRhinoGetPolygon::EdgeStartPrompt | ( | ) | const |
void CArgsRhinoGetPolygon::EnablePyramidOption | ( | bool | = true | ) |
void CArgsRhinoGetPolygon::EnableVerticalPolygonOption | ( | bool | = true | ) |
const ON_3dPoint& CArgsRhinoGetPolygon::FirstPoint | ( | ) | const |
const BOOL32 CArgsRhinoGetPolygon::Flip | ( | ) | const |
unsigned int CArgsRhinoGetPolygon::GetCap | ( | ) | const |
const BOOL32 CArgsRhinoGetPolygon::GettingStarModePolygon | ( | ) | const |
const BOOL32 CArgsRhinoGetPolygon::Inscribed | ( | ) | const |
const ON_wString& CArgsRhinoGetPolygon::InscribedAroundCurveCenterPrompt | ( | ) | const |
const ON_wString& CArgsRhinoGetPolygon::InscribedCenterPrompt | ( | ) | const |
gets
const ON_3dVector& CArgsRhinoGetPolygon::Normal | ( | ) | const |
int CArgsRhinoGetPolygon::NumSides | ( | ) | const |
CArgsRhinoGetPolygon& CArgsRhinoGetPolygon::operator= | ( | const CArgsRhinoGetPolygon & | ) |
const int CArgsRhinoGetPolygon::PyramidConstraint | ( | ) | const |
const bool CArgsRhinoGetPolygon::PyramidOptionAvailable | ( | ) | const |
const ON_3dPoint& CArgsRhinoGetPolygon::SecondPoint | ( | ) | const |
void CArgsRhinoGetPolygon::SetAroundCurve | ( | BOOL32 | ) |
void CArgsRhinoGetPolygon::SetCap | ( | unsigned int | ) |
void CArgsRhinoGetPolygon::SetCircle | ( | const ON_Circle & | ) |
void CArgsRhinoGetPolygon::SetCircumscribedAroundCurveCenterPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetPolygon::SetCircumscribedCenterPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetPolygon::SetCornerPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetPolygon::SetCurve | ( | const ON_Curve * | ) |
void CArgsRhinoGetPolygon::SetEdgeEndPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetPolygon::SetEdgeMidpointPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetPolygon::SetEdgeMode | ( | BOOL32 | ) |
void CArgsRhinoGetPolygon::SetEdgeStartPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetPolygon::SetFirstPoint | ( | const ON_3dPoint & | ) |
void CArgsRhinoGetPolygon::SetFlip | ( | BOOL32 | ) |
void CArgsRhinoGetPolygon::SetGettingStarModePolygon | ( | BOOL32 | ) |
void CArgsRhinoGetPolygon::SetInscribed | ( | BOOL32 | ) |
void CArgsRhinoGetPolygon::SetInscribedAroundCurveCenterPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetPolygon::SetInscribedCenterPrompt | ( | const wchar_t * | ) |
sets
void CArgsRhinoGetPolygon::SetNormal | ( | const ON_3dVector & | ) |
void CArgsRhinoGetPolygon::SetNumSides | ( | int | ) |
void CArgsRhinoGetPolygon::SetPyramidConstraint | ( | int | ) |
void CArgsRhinoGetPolygon::SetSecondPoint | ( | const ON_3dPoint & | ) |
void CArgsRhinoGetPolygon::SetStarAroundCurveCenterPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetPolygon::SetStarCenterPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetPolygon::SetStarEndPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetPolygon::SetStarMode | ( | BOOL32 | ) |
void CArgsRhinoGetPolygon::SetStarSecondRadius | ( | double | ) |
void CArgsRhinoGetPolygon::SetStarSecondRadiusPrompt | ( | const wchar_t * | ) |
void CArgsRhinoGetPolygon::SetUseActiveLayerLinetype | ( | bool | on | ) |
When true the linetype of the active layer is used for dynamic drawing.
void CArgsRhinoGetPolygon::SetUseFirstPoint | ( | BOOL32 | ) |
void CArgsRhinoGetPolygon::SetUseNormal | ( | BOOL32 | ) |
void CArgsRhinoGetPolygon::SetUseStarSecondRadius | ( | BOOL32 | ) |
void CArgsRhinoGetPolygon::SetVertical | ( | BOOL32 | ) |
const ON_wString& CArgsRhinoGetPolygon::StarAroundCurveCenterPrompt | ( | ) | const |
const ON_wString& CArgsRhinoGetPolygon::StarCenterPrompt | ( | ) | const |
const ON_wString& CArgsRhinoGetPolygon::StarEndPrompt | ( | ) | const |
const BOOL32 CArgsRhinoGetPolygon::StarMode | ( | ) | const |
double CArgsRhinoGetPolygon::StarSecondRadius | ( | ) | const |
const ON_wString& CArgsRhinoGetPolygon::StarSecondRadiusPrompt | ( | ) | const |
bool CArgsRhinoGetPolygon::UseActiveLayerLinetype | ( | ) | const |
const BOOL32 CArgsRhinoGetPolygon::UseFirstPoint | ( | ) | const |
const BOOL32 CArgsRhinoGetPolygon::UseNormal | ( | ) | const |
const BOOL32 CArgsRhinoGetPolygon::UseStarSecondRadius | ( | ) | const |
const BOOL32 CArgsRhinoGetPolygon::Vertical | ( | ) | const |
const bool CArgsRhinoGetPolygon::VerticalPolygonOptionAvailable | ( | ) | const |
|
protected |
|
protected |
|
protected |
|
protected |
0 = None, 1 = Vertical, 2 = AroundCurve
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
true=polygon by edge
|
protected |
|
protected |
|
protected |
|
protected |
true=inscribed, false=circumscribed
|
protected |
|
protected |
|
protected |
int CArgsRhinoGetPolygon::m_NumSides |
variables
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
true=star
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |