Rhino C++ API
8.13
|
#include <rhinoSdkGetSubCurve.h>
Public Member Functions | |
CArgsRhinoGetSubCurve () | |
CArgsRhinoGetSubCurve (const CArgsRhinoGetSubCurve &) | |
~CArgsRhinoGetSubCurve () | |
void | ClearIncludeRange () |
const ON_Curve * | Curve () const |
const ON_wString & | FirstPrompt () const |
gets More... | |
bool | IncludeRange (ON_Interval &range) const |
bool | IncludeRangeValid () const |
CArgsRhinoGetSubCurve & | operator= (const CArgsRhinoGetSubCurve &) |
bool | Reverse () const |
const ON_wString & | SecondPrompt () const |
void | SetCurve (const ON_Curve *pC) |
void | SetFirstPrompt (const wchar_t *) |
sets More... | |
void | SetIncludeRange (const ON_Interval &range) |
void | SetReverse (bool bRev) |
void | SetSecondPrompt (const wchar_t *) |
Protected Attributes | |
bool | m_bReverse |
true if drag direction was opposite natural curve direction More... | |
ON_wString | m_FirstPrompt |
prompt for first point More... | |
ON_Interval | m_include_range |
const ON_Curve * | m_pC |
ON_wString | m_SecondPrompt |
prompt for following points More... | |
Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer.
CLASS CArgsRhinoGetSubCurve
OVERVIEW TEXT Arguments for RhinoGetSubCurve
KEYWORDS
CArgsRhinoGetSubCurve::CArgsRhinoGetSubCurve | ( | ) |
CArgsRhinoGetSubCurve::~CArgsRhinoGetSubCurve | ( | ) |
CArgsRhinoGetSubCurve::CArgsRhinoGetSubCurve | ( | const CArgsRhinoGetSubCurve & | ) |
void CArgsRhinoGetSubCurve::ClearIncludeRange | ( | ) |
const ON_Curve* CArgsRhinoGetSubCurve::Curve | ( | ) | const |
const ON_wString& CArgsRhinoGetSubCurve::FirstPrompt | ( | ) | const |
gets
bool CArgsRhinoGetSubCurve::IncludeRange | ( | ON_Interval & | range | ) | const |
bool CArgsRhinoGetSubCurve::IncludeRangeValid | ( | ) | const |
CArgsRhinoGetSubCurve& CArgsRhinoGetSubCurve::operator= | ( | const CArgsRhinoGetSubCurve & | ) |
bool CArgsRhinoGetSubCurve::Reverse | ( | ) | const |
const ON_wString& CArgsRhinoGetSubCurve::SecondPrompt | ( | ) | const |
void CArgsRhinoGetSubCurve::SetCurve | ( | const ON_Curve * | pC | ) |
void CArgsRhinoGetSubCurve::SetFirstPrompt | ( | const wchar_t * | ) |
sets
void CArgsRhinoGetSubCurve::SetIncludeRange | ( | const ON_Interval & | range | ) |
void CArgsRhinoGetSubCurve::SetReverse | ( | bool | bRev | ) |
void CArgsRhinoGetSubCurve::SetSecondPrompt | ( | const wchar_t * | ) |
|
protected |
true if drag direction was opposite natural curve direction
|
protected |
prompt for first point
|
protected |
|
protected |
|
protected |
prompt for following points