Rhino C++ API
8.13
|
#include <rhinoSdkGetPlane.h>
Public Member Functions | |
CArgsRhinoGetThickBox () | |
CArgsRhinoGetThickBox (const CArgsRhinoGetThickBox &) | |
virtual | ~CArgsRhinoGetThickBox () |
const bool | AddThickness () const |
CArgsRhinoGetThickBox & | operator= (const CArgsRhinoGetThickBox &) |
void | SetAddThickness (const bool) |
void | SetThickness (const double) |
void | SetThicknessOption (const CRhinoCommandOptionName &) |
void | SetThicknessPrompt (const wchar_t *) |
const double | Thickness () const |
const CRhinoCommandOptionName & | ThicknessOption () const |
const wchar_t * | ThicknessPrompt () const |
Public Member Functions inherited from CArgsRhinoGetBox | |
CArgsRhinoGetBox () | |
CArgsRhinoGetBox (const CArgsRhinoGetBox &) | |
virtual | ~CArgsRhinoGetBox () |
const wchar_t * | HeightPrompt () const |
CArgsRhinoGetBox & | operator= (const CArgsRhinoGetBox &) |
void | SetHeightPrompt (const wchar_t *height_prompt) |
Public Member Functions inherited from CArgsRhinoGetPlane | |
CArgsRhinoGetPlane () | |
CArgsRhinoGetPlane (const CArgsRhinoGetPlane &src) | |
virtual | ~CArgsRhinoGetPlane () |
void | AcceptNothing (bool bAcceptNothing=true) |
Like CRhinoGet::AcceptNothing(). More... | |
virtual void | AddExtraOptions (CRhinoGetPoint &gp) |
Allows for adding extra command options during RhinoGetRectangle. More... | |
BOOL32 | Allow3Point () |
BOOL32 | AllowCenter () |
BOOL32 | AllowCorners () |
BOOL32 | AllowDeformable () const |
BOOL32 | AllowForceAspectRatio () |
BOOL32 | AllowRounded () |
BOOL32 | AllowVertical () |
int | ArgsType () const |
return type of args class plane or derived box More... | |
int | CornerMode () |
double | CornerRadius () |
double | CornerRho () |
int | CurrentMode () |
BOOL32 | Deformable () const |
bool | DrawPicture () |
std::function< void(const ON_3dPoint[4])> | DynamicRectangleCallback () const |
virtual bool | ExtraOptionsAtStart () const |
ON_Color | FeedbackColor () const |
color used to draw feedback line More... | |
int | FirstDirectionCount () const |
number of faces in first direction More... | |
int | FirstDirectionMinCount () const |
const CRhinoCommandOptionName & | FirstMeshDensityDirectionPrompt () const |
prompt for number of faces in first direction More... | |
const ON_3dPoint & | FirstPoint () const |
const wchar_t * | FirstPointPrompt3Point () const |
prompt when getting first corner More... | |
const wchar_t * | FirstPointPromptCenter () const |
prompt when getting center in center mode More... | |
const wchar_t * | FirstPointPromptCorners () const |
prompt when getting first corner More... | |
const wchar_t * | FirstPointPromptVertical () const |
prompt when getting first corner More... | |
double | ForcedAspectRatio () |
virtual void | HandleExtraOptions (const CRhinoGetPoint &gp) |
BOOL32 | HaveFirstPoint () const |
BOOL32 | HavePlane () const |
BOOL32 | HaveSecondPoint () const |
BOOL32 | HaveThirdPoint () const |
double | Length () |
CArgsRhinoGetPlane & | operator= (const CArgsRhinoGetPlane &src) |
const wchar_t * | PictureFileName () const |
const ON_Plane & | Plane () const |
bool | PromptForMeshDensity () const |
BOOL32 | Rounded () |
int | SecondDirectionCount () const |
number of faces in second direction More... | |
int | SecondDirectionMinCount () const |
const CRhinoCommandOptionName & | SecondMeshDensityDirectionPrompt () const |
prompt for number of faces in second direction More... | |
const ON_3dPoint & | SecondPoint () const |
const wchar_t * | SecondPointPrompt3Point () const |
prompt when getting second point in 3 point mode More... | |
const wchar_t * | SecondPointPromptCenter () const |
prompt when getting corner in center mode More... | |
const wchar_t * | SecondPointPromptCorners () const |
prompt when getting opposite corner More... | |
const wchar_t * | SecondPointPromptVertical () const |
prompt when getting second point in vertical mode More... | |
void | SetAllow3Point (BOOL32 allow=TRUE) |
void | SetAllowCenter (BOOL32 allow=TRUE) |
void | SetAllowCorners (BOOL32 allow=TRUE) |
void | SetAllowDeformable (BOOL32 b=TRUE) |
void | SetAllowForceAspectRatio (BOOL32 allow=TRUE) |
void | SetAllowRounded (BOOL32 allow=FALSE) |
void | SetAllowVertical (BOOL32 allow=TRUE) |
void | SetCornerMode (int mode=corner_arc) |
void | SetCornerRadius (double radius) |
void | SetCornerRho (double rho) |
void | SetCurrentMode (int mode=mode_corners) |
void | SetDeformable (BOOL32 bDeformable=TRUE) |
void | SetDynamicRectangleCallback (std::function< void(const ON_3dPoint[4])> callback) |
void | SetFeedbackColor (COLORREF color) |
void | SetFirstDirectionCount (int count) |
void | SetFirstDirectionMinCount (int count) |
void | SetFirstMeshDensityDirectionPrompt (const CRhinoCommandOptionName &) |
void | SetFirstPoint (const ON_3dPoint &base) |
void | SetFirstPointPrompt3Point (const wchar_t *prompt) |
void | SetFirstPointPromptCenter (const wchar_t *prompt) |
void | SetFirstPointPromptCorners (const wchar_t *prompt) |
void | SetFirstPointPromptVertical (const wchar_t *prompt) |
void | SetForcedAspectRatio (double forced_aspect_ratio) |
void | SetHaveFirstPoint (BOOL32 b=TRUE) |
void | SetHavePlane (BOOL32 b=TRUE) |
void | SetHaveSecondPoint (BOOL32 b=TRUE) |
void | SetHaveThirdPoint (BOOL32 b=TRUE) |
void | SetLength (double length) |
void | SetPictureFileNameAndSize (const wchar_t *filename, int width, int height) |
void | SetPlane (const ON_Plane &plane) |
void | SetPromptForMeshDensity (bool bMeshDensity=true) |
void | SetRounded (BOOL32 allow=FALSE) |
void | SetSecondDirectionCount (int count) |
void | SetSecondDirectionMinCount (int count) |
void | SetSecondMeshDensityDirectionPrompt (const CRhinoCommandOptionName &) |
void | SetSecondPoint (const ON_3dPoint &point) |
void | SetSecondPointPrompt3Point (const wchar_t *prompt) |
void | SetSecondPointPromptCenter (const wchar_t *prompt) |
void | SetSecondPointPromptCorners (const wchar_t *prompt) |
void | SetSecondPointPromptVertical (const wchar_t *prompt) |
void | SetThirdDirectionCount (int count) |
void | SetThirdDirectionMinCount (int count) |
void | SetThirdMeshDensityDirectionPrompt (const CRhinoCommandOptionName &) |
void | SetThirdPoint (const ON_3dPoint &point) |
void | SetThirdPointPrompt3Point (const wchar_t *prompt) |
void | SetThirdPointPromptVertical (const wchar_t *prompt) |
void | SetUDegree (int degree) |
void | SetUPointCount (int count) |
void | SetUseActiveLayerLinetype (bool on) |
When true the linetype of the active layer is used for dynamic drawing. More... | |
void | SetVDegree (int degree) |
void | SetVPointCount (int count) |
void | SetWidth (double width) |
int | ThirdDirectionCount () const |
number of faces in third direction More... | |
int | ThirdDirectionMinCount () const |
const CRhinoCommandOptionName & | ThirdMeshDensityDirectionPrompt () const |
prompt for number of faces in third direction More... | |
const ON_3dPoint & | ThirdPoint () const |
const wchar_t * | ThirdPointPrompt3Point () const |
prompt when getting opposite side in 3point mode More... | |
const wchar_t * | ThirdPointPromptVertical () const |
prompt when getting opposite side in vertical mode More... | |
int | UDegree () const |
int | UPointCount () const |
bool | UseActiveLayerLinetype () const |
int | VDegree () const |
int | VPointCount () const |
double | Width () |
Additional Inherited Members | |
Public Types inherited from CArgsRhinoGetPlane | |
enum | { mode_corners, mode_3point, mode_vertical, mode_center, mode_3point_mid, mode_3point_center } |
enum | { corner_arc = 0, corner_conic = 1, corner_chamfer = 2 } |
enum | { plane_type = 0, box_type = 1, plane_type_ex = 2, detail_type = 3 } |
Public Attributes inherited from CArgsRhinoGetBox | |
ON_wString | m_height_prompt |
Public Attributes inherited from CArgsRhinoGetPlane | |
bool | m_bAcceptNothing |
int | m_simple_option_index |
ON_ClassArray< CRhinoCommandOptionName > | m_simple_options |
input - simple options to add to the first prompt; More... | |
CArgsRhinoGetThickBox::CArgsRhinoGetThickBox | ( | ) |
|
virtual |
CArgsRhinoGetThickBox::CArgsRhinoGetThickBox | ( | const CArgsRhinoGetThickBox & | ) |
const bool CArgsRhinoGetThickBox::AddThickness | ( | ) | const |
CArgsRhinoGetThickBox& CArgsRhinoGetThickBox::operator= | ( | const CArgsRhinoGetThickBox & | ) |
void CArgsRhinoGetThickBox::SetAddThickness | ( | const bool | ) |
void CArgsRhinoGetThickBox::SetThickness | ( | const double | ) |
void CArgsRhinoGetThickBox::SetThicknessOption | ( | const CRhinoCommandOptionName & | ) |
void CArgsRhinoGetThickBox::SetThicknessPrompt | ( | const wchar_t * | ) |
const double CArgsRhinoGetThickBox::Thickness | ( | ) | const |
const CRhinoCommandOptionName& CArgsRhinoGetThickBox::ThicknessOption | ( | ) | const |
const wchar_t* CArgsRhinoGetThickBox::ThicknessPrompt | ( | ) | const |
|
protected |