Rhino C++ API
8.13
|
CArgsRhinoMatch is obsolete. More...
#include <RhinoSdkMatch.h>
Public Types | |
enum | eMatchJoin { mjNone = 0, mjJoin = 1, mjMerge = 2 } |
enum | eMatchMode { smPosition = 0, smTangency = 1, smCurvature = 2 } |
Public Member Functions | |
CArgsRhinoMatch () | |
~CArgsRhinoMatch () | |
Public Attributes | |
bool | m_bAverage |
change both curves by 1/2 each More... | |
bool | m_bFlipDirection |
Match opposite target direction. More... | |
bool | m_bMatchPickPoint |
Matching to a point on a curve (m_curvesin[1]) at m_trim_param. More... | |
bool | m_bOneCurve |
true if both ends of one curve are being matched More... | |
bool | m_bPerpToEdge |
Match curve perpendicular to surface edge. More... | |
eMatchMode | m_continuity |
ON_NurbsCurve * | m_curvesin [2] |
Nurbs form duplicates of the input curves. More... | |
ON_NurbsCurve * | m_curvesout [2] |
Result curves after the match. More... | |
eMatchJoin | m_join |
No operator= – curve pointers copied in assignment. More... | |
int | m_preserve |
double | m_target_param |
parameter on the curve to match More... | |
const ON_BrepTrim * | m_trim |
A brep trim for matching to a surface edge. More... | |
CArgsRhinoMatch is obsolete.
Copyright (c) 1993-2024 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer.
CArgsRhinoMatch::CArgsRhinoMatch | ( | ) |
CArgsRhinoMatch::~CArgsRhinoMatch | ( | ) |
bool CArgsRhinoMatch::m_bAverage |
change both curves by 1/2 each
bool CArgsRhinoMatch::m_bFlipDirection |
Match opposite target direction.
bool CArgsRhinoMatch::m_bMatchPickPoint |
Matching to a point on a curve (m_curvesin[1]) at m_trim_param.
bool CArgsRhinoMatch::m_bOneCurve |
true if both ends of one curve are being matched
bool CArgsRhinoMatch::m_bPerpToEdge |
Match curve perpendicular to surface edge.
eMatchMode CArgsRhinoMatch::m_continuity |
what geometry characteristics to match 0:position, 1:tangency, 2:curvature
ON_NurbsCurve* CArgsRhinoMatch::m_curvesin[2] |
Nurbs form duplicates of the input curves.
ON_NurbsCurve* CArgsRhinoMatch::m_curvesout[2] |
Result curves after the match.
eMatchJoin CArgsRhinoMatch::m_join |
No operator= – curve pointers copied in assignment.
none, join, merge
int CArgsRhinoMatch::m_preserve |
maintain shape of the edge opposite the one being edited 0 : nothing 1 : position 2 : tangency 3 : curvature
double CArgsRhinoMatch::m_target_param |
parameter on the curve to match
const ON_BrepTrim* CArgsRhinoMatch::m_trim |
A brep trim for matching to a surface edge.