Rhino C++ API
8.13
|
#include <rhinoSdkGetText.h>
Public Member Functions | |
CArgsRhinoText () | |
CArgsRhinoText (const CArgsRhinoText &)=default | |
CArgsRhinoText (unsigned int rhino_doc_sn, const ON_3dPoint *start_point, const wchar_t *string) | |
~CArgsRhinoText ()=default | |
int | DimStyleIndex () const |
Current text style is used if its not forced here. More... | |
int | DimStyleIndex (const CRhinoDoc &doc) const |
bool | HaveStartPoint () const |
bool | HaveString () const |
double | Height () const |
bool | IsInteractive () |
Set or get whether the command is being run interaceively. More... | |
CArgsRhinoText & | operator= (const CArgsRhinoText &)=default |
void | SetDefaultPrompts () |
void | SetDimStyleIndex (const CRhinoDoc &doc, int test_style_index) |
void | SetHeight (double height) |
void | SetInteractive (bool interactive) |
void | SetStartPoint (const ON_3dPoint &start_point) |
void | SetStartPointPrompt (const wchar_t *prompt) |
void | SetString (const wchar_t *string) |
void | SetStringPrompt (const wchar_t *prompt) |
const ON_3dPoint * | StartPoint () const |
Text start point. More... | |
const wchar_t * | StartPointPrompt () const |
prompt when getting start point More... | |
const wchar_t * | String () const |
const wchar_t * | StringPrompt () const |
prompt when getting the text string More... | |
Protected Attributes | |
int | m_dim_style_index = -1 |
[in] font index in the Rhino text style table More... | |
bool | m_havepoint = false |
bool | m_havestring = false |
double | m_height = 1.0 |
bool | m_interactive = true |
ON_wString | m_promptstartpoint |
[in] prompt when getting start point More... | |
ON_wString | m_promptstring |
[in] prompt when getting the text string More... | |
ON_3dPoint | m_startpoint = ON_3dPoint::Origin |
ON_wString | m_string = ON_wString::EmptyString |
Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. Description: CArgsRhinoText is used to pass input to RhinoGetText().
CArgsRhinoText::CArgsRhinoText | ( | ) |
|
default |
|
default |
CArgsRhinoText::CArgsRhinoText | ( | unsigned int | rhino_doc_sn, |
const ON_3dPoint * | start_point, | ||
const wchar_t * | string | ||
) |
int CArgsRhinoText::DimStyleIndex | ( | ) | const |
Current text style is used if its not forced here.
Returns: -1: Use document default
int CArgsRhinoText::DimStyleIndex | ( | const CRhinoDoc & | doc | ) | const |
bool CArgsRhinoText::HaveStartPoint | ( | ) | const |
bool CArgsRhinoText::HaveString | ( | ) | const |
double CArgsRhinoText::Height | ( | ) | const |
bool CArgsRhinoText::IsInteractive | ( | ) |
Set or get whether the command is being run interaceively.
|
default |
void CArgsRhinoText::SetDefaultPrompts | ( | ) |
void CArgsRhinoText::SetDimStyleIndex | ( | const CRhinoDoc & | doc, |
int | test_style_index | ||
) |
void CArgsRhinoText::SetHeight | ( | double | height | ) |
void CArgsRhinoText::SetInteractive | ( | bool | interactive | ) |
void CArgsRhinoText::SetStartPoint | ( | const ON_3dPoint & | start_point | ) |
void CArgsRhinoText::SetStartPointPrompt | ( | const wchar_t * | prompt | ) |
void CArgsRhinoText::SetString | ( | const wchar_t * | string | ) |
void CArgsRhinoText::SetStringPrompt | ( | const wchar_t * | prompt | ) |
const ON_3dPoint* CArgsRhinoText::StartPoint | ( | ) | const |
Text start point.
const wchar_t* CArgsRhinoText::StartPointPrompt | ( | ) | const |
prompt when getting start point
const wchar_t* CArgsRhinoText::String | ( | ) | const |
const wchar_t* CArgsRhinoText::StringPrompt | ( | ) | const |
prompt when getting the text string
|
protected |
[in] font index in the Rhino text style table
-1 means use doc default
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
[in] prompt when getting start point
|
protected |
[in] prompt when getting the text string
|
protected |
|
protected |