Rhino C++ API
8.18
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
CChannelAttributes Member List
This is the complete list of members for
CChannelAttributes
, including all inherited members.
CChannelAttributes
()
CChannelAttributes
EnableBackgroundAttrs
(bool=true)
CChannelAttributes
EnableGridAndAxesAttrs
(bool=true)
CChannelAttributes
InitAttributes
()
CChannelAttributes
m_bAxesDrawn
CChannelAttributes
m_bBgBitmapDrawn
CChannelAttributes
m_bDrawBackgroundBitmap
CChannelAttributes
m_bDrawConstructionAxes
CChannelAttributes
m_bDrawConstructionGrid
CChannelAttributes
m_bDrawConstructionGridOnTop
CChannelAttributes
m_bDrawObject
CChannelAttributes
m_bDrawWallpaper
CChannelAttributes
m_bDrawWorldAxes
CChannelAttributes
m_bDrawZAxis
CChannelAttributes
m_bFramebufferCleared
CChannelAttributes
m_bFrameBufferModified
CChannelAttributes
m_bGridDrawn
CChannelAttributes
m_bHiddenLineRemoval
CChannelAttributes
m_bObjectColorOverridden
CChannelAttributes
m_bObjectReplaced
CChannelAttributes
m_BoundingBox
CChannelAttributes
m_bSortByDistance
CChannelAttributes
m_bUseExclusiveBBox
CChannelAttributes
m_bUseMeshingParms
CChannelAttributes
m_bWallpaperDrawn
CChannelAttributes
m_bWorldAxesDrawn
CChannelAttributes
m_ClippingPlanes
CChannelAttributes
m_dBottom
CChannelAttributes
m_dFar
CChannelAttributes
m_dLeft
CChannelAttributes
m_dNear
CChannelAttributes
m_dRight
CChannelAttributes
m_dTop
CChannelAttributes
m_eFrameBufferFillMode
CChannelAttributes
m_eLightingScheme
CChannelAttributes
m_GradBotLeft
CChannelAttributes
m_GradBotRight
CChannelAttributes
m_GradTopLeft
CChannelAttributes
m_GradTopRight
CChannelAttributes
m_Lights
CChannelAttributes
m_MeshingParms
CChannelAttributes
m_nActiveChannel
CChannelAttributes
m_nObjectIndex
CChannelAttributes
m_nRenderPass
CChannelAttributes
m_pBgBitmap
CChannelAttributes
m_pFrameBuffer
CChannelAttributes
m_pObject
CChannelAttributes
m_SolidColor
CChannelAttributes
PopulateChannelAttrs
(CChannelAttributes &, UINT)
CChannelAttributes
Generated on Tue Apr 8 2025 16:23:45 for Rhino C++ API by
1.8.17