Rhino C++ API  8.5
Public Member Functions | Public Attributes | List of all members
CChannelAttributes Class Reference

#include <rhinoSdkChannelAttributes.h>

Public Member Functions

 CChannelAttributes ()
 
void EnableBackgroundAttrs (bool=true)
 
void EnableGridAndAxesAttrs (bool=true)
 
bool InitAttributes ()
 
bool PopulateChannelAttrs (CChannelAttributes &, UINT)
 

Public Attributes

bool m_bAxesDrawn
 
bool m_bBgBitmapDrawn
 
bool m_bDrawBackgroundBitmap
 
bool m_bDrawConstructionAxes
 
bool m_bDrawConstructionGrid
 
bool m_bDrawConstructionGridOnTop
 Draw background conduit channel attributes... More...
 
bool m_bDrawObject
 Draw object AND Object Culling conduit channel attributes... More...
 
bool m_bDrawWallpaper
 
bool m_bDrawWorldAxes
 
bool m_bDrawZAxis
 
bool m_bFramebufferCleared
 Init framebuffer conduit channel attributes... More...
 
bool m_bFrameBufferModified
 Post Processing Frame Buffer conduit channel attributes... More...
 
bool m_bGridDrawn
 
bool m_bHiddenLineRemoval
 
bool m_bObjectColorOverridden
 
bool m_bObjectReplaced
 
ON_BoundingBox m_BoundingBox
 
bool m_bSortByDistance
 Draw middleground conduit channel attributes... More...
 
bool m_bUseExclusiveBBox
 Calc BoundingBox conduit channel attributes... More...
 
bool m_bUseMeshingParms
 Meshing Parameters conduit channel attributes... More...
 
bool m_bWallpaperDrawn
 
bool m_bWorldAxesDrawn
 Draw foreground conduit channel attributes... More...
 
ON_SimpleArray< ON_ClippingPlaneInfom_ClippingPlanes
 
double m_dBottom
 
double m_dFar
 
double m_dLeft
 
double m_dNear
 
double m_dRight
 
double m_dTop
 
EFrameBufferFillMode m_eFrameBufferFillMode
 
ELightingScheme m_eLightingScheme
 Setup Lighting conduit channel attributes... More...
 
ON_Color m_GradBotLeft
 
ON_Color m_GradBotRight
 
ON_Color m_GradTopLeft
 
ON_Color m_GradTopRight
 
ON_ObjectArray< ON_Lightm_Lights
 
ON_MeshParameters m_MeshingParms
 
UINT m_nActiveChannel
 
int m_nObjectIndex
 
UINT m_nRenderPass
 
std::shared_ptr< const CRhinoDibm_pBgBitmap
 
CRhinoDibm_pFrameBuffer
 
const CRhinoObjectm_pObject
 
ON_Color m_SolidColor
 

Constructor & Destructor Documentation

◆ CChannelAttributes()

CChannelAttributes::CChannelAttributes ( )

Member Function Documentation

◆ EnableBackgroundAttrs()

void CChannelAttributes::EnableBackgroundAttrs ( bool  = true)

◆ EnableGridAndAxesAttrs()

void CChannelAttributes::EnableGridAndAxesAttrs ( bool  = true)

◆ InitAttributes()

bool CChannelAttributes::InitAttributes ( )

◆ PopulateChannelAttrs()

bool CChannelAttributes::PopulateChannelAttrs ( CChannelAttributes ,
UINT   
)

Member Data Documentation

◆ m_bAxesDrawn

bool CChannelAttributes::m_bAxesDrawn

◆ m_bBgBitmapDrawn

bool CChannelAttributes::m_bBgBitmapDrawn

◆ m_bDrawBackgroundBitmap

bool CChannelAttributes::m_bDrawBackgroundBitmap

◆ m_bDrawConstructionAxes

bool CChannelAttributes::m_bDrawConstructionAxes

◆ m_bDrawConstructionGrid

bool CChannelAttributes::m_bDrawConstructionGrid

◆ m_bDrawConstructionGridOnTop

bool CChannelAttributes::m_bDrawConstructionGridOnTop

Draw background conduit channel attributes...

◆ m_bDrawObject

bool CChannelAttributes::m_bDrawObject

Draw object AND Object Culling conduit channel attributes...

◆ m_bDrawWallpaper

bool CChannelAttributes::m_bDrawWallpaper

◆ m_bDrawWorldAxes

bool CChannelAttributes::m_bDrawWorldAxes

◆ m_bDrawZAxis

bool CChannelAttributes::m_bDrawZAxis

◆ m_bFramebufferCleared

bool CChannelAttributes::m_bFramebufferCleared

Init framebuffer conduit channel attributes...

◆ m_bFrameBufferModified

bool CChannelAttributes::m_bFrameBufferModified

Post Processing Frame Buffer conduit channel attributes...

◆ m_bGridDrawn

bool CChannelAttributes::m_bGridDrawn

◆ m_bHiddenLineRemoval

bool CChannelAttributes::m_bHiddenLineRemoval

◆ m_bObjectColorOverridden

bool CChannelAttributes::m_bObjectColorOverridden

◆ m_bObjectReplaced

bool CChannelAttributes::m_bObjectReplaced

◆ m_BoundingBox

ON_BoundingBox CChannelAttributes::m_BoundingBox

◆ m_bSortByDistance

bool CChannelAttributes::m_bSortByDistance

Draw middleground conduit channel attributes...

◆ m_bUseExclusiveBBox

bool CChannelAttributes::m_bUseExclusiveBBox

Calc BoundingBox conduit channel attributes...

◆ m_bUseMeshingParms

bool CChannelAttributes::m_bUseMeshingParms

Meshing Parameters conduit channel attributes...

◆ m_bWallpaperDrawn

bool CChannelAttributes::m_bWallpaperDrawn

◆ m_bWorldAxesDrawn

bool CChannelAttributes::m_bWorldAxesDrawn

Draw foreground conduit channel attributes...

◆ m_ClippingPlanes

ON_SimpleArray<ON_ClippingPlaneInfo> CChannelAttributes::m_ClippingPlanes

◆ m_dBottom

double CChannelAttributes::m_dBottom

◆ m_dFar

double CChannelAttributes::m_dFar

◆ m_dLeft

double CChannelAttributes::m_dLeft

Setup Frustum conduit channel attributes... m_dLeft, ..., m_dBottom are typically the view frustum's left,right,top,bottom values, but since you don't reliably know the view frustum's near and far values, m_dLeft, ..., m_dBottom are useless in perspective views.

◆ m_dNear

double CChannelAttributes::m_dNear

Calc clipping planes conduit channel attributes... The m_dNear and m_dFar values often correspond to the CRhinoDisplayPipeline.m_Clipping.m_bbox_near and CRhinoDisplayPipeline.m_Clipping.m_bbox_far values. In particular, it is common for m_dNear and m_dFar to be different from the view frustum's near/far values. This unfortunate situation cannot be fixed until we ship Rhino 6.0.

◆ m_dRight

double CChannelAttributes::m_dRight

◆ m_dTop

double CChannelAttributes::m_dTop

◆ m_eFrameBufferFillMode

EFrameBufferFillMode CChannelAttributes::m_eFrameBufferFillMode

◆ m_eLightingScheme

ELightingScheme CChannelAttributes::m_eLightingScheme

Setup Lighting conduit channel attributes...

◆ m_GradBotLeft

ON_Color CChannelAttributes::m_GradBotLeft

◆ m_GradBotRight

ON_Color CChannelAttributes::m_GradBotRight

◆ m_GradTopLeft

ON_Color CChannelAttributes::m_GradTopLeft

◆ m_GradTopRight

ON_Color CChannelAttributes::m_GradTopRight

◆ m_Lights

ON_ObjectArray<ON_Light> CChannelAttributes::m_Lights

◆ m_MeshingParms

ON_MeshParameters CChannelAttributes::m_MeshingParms

◆ m_nActiveChannel

UINT CChannelAttributes::m_nActiveChannel

Attributes are broken down and organized into their relevant pipeline channels.

Note: accessing and/or setting attributes outside their required channel is an unknown behavior or operation. Besides, the pipeline initializes these attributes on a per-channel basis, so for example, setting an attribute designated for DrawMiddleground channels from within a DrawBackground channel has no affect.

◆ m_nObjectIndex

int CChannelAttributes::m_nObjectIndex

◆ m_nRenderPass

UINT CChannelAttributes::m_nRenderPass

◆ m_pBgBitmap

std::shared_ptr<const CRhinoDib> CChannelAttributes::m_pBgBitmap

◆ m_pFrameBuffer

CRhinoDib* CChannelAttributes::m_pFrameBuffer

◆ m_pObject

const CRhinoObject* CChannelAttributes::m_pObject

◆ m_SolidColor

ON_Color CChannelAttributes::m_SolidColor