Rhino C++ API  8.5
Public Member Functions | Public Attributes | List of all members
CLinesDescriptor Class Reference

Lines helper class used to describe and draw large chunks of lines. More...

#include <rhinoSdkDisplayEngineAttributes.h>

Public Member Functions

 CLinesDescriptor (const ON_3dPoint *points, int count)
 

Public Attributes

ON_Color m_Color
 
int m_Count
 number of points in m_Points More...
 
UINT m_Pattern = 0xFFFFFFFF
 
const ON_3dPointm_Points
 
int m_Thickness = 1
 

Detailed Description

Lines helper class used to describe and draw large chunks of lines.

Constructor & Destructor Documentation

◆ CLinesDescriptor()

CLinesDescriptor::CLinesDescriptor ( const ON_3dPoint points,
int  count 
)
inline

Member Data Documentation

◆ m_Color

ON_Color CLinesDescriptor::m_Color

◆ m_Count

int CLinesDescriptor::m_Count

number of points in m_Points

individual line segment pairs. (moveto, lineto), (moveto, lineto),...

◆ m_Pattern

UINT CLinesDescriptor::m_Pattern = 0xFFFFFFFF

◆ m_Points

const ON_3dPoint* CLinesDescriptor::m_Points

consecutive points that make up

◆ m_Thickness

int CLinesDescriptor::m_Thickness = 1