Rhino C++ API
8.13
|
#include <RhRdkBasicMaterial.h>
Public Member Functions | |
CTextureSlot (const CTextureSlot &slot) | |
double | Amount (void) const |
ON_wString | ChildSlotName (void) const |
bool | FilterOn (void) const |
ON_wString | InternalName (void) const |
bool | On (void) const |
bool | operator!= (const CTextureSlot &slot) |
const CTextureSlot & | operator= (const CTextureSlot &slot) |
bool | operator== (const CTextureSlot &slot) |
void | ReadParametersFromSection (const IRhRdk_XMLSection §ion, CRhRdkContent::ReadParamsContext context) |
void | SetAmount (double d) |
void | SetField (CRhRdkTexturedContentField *p) |
void | SetFilterOn (bool b) |
void | SetOn (bool b) |
void | SetSimulation (IRhRdk_XMLSection §ion) const |
void | WriteParametersToSection (IRhRdk_XMLSection §ion, CRhRdkContent::WriteParamsContext context) const |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Public Attributes | |
RDK_DEPRECATED bool | m_bFilterOn |
RDK_DEPRECATED bool | m_bOn |
RDK_DEPRECATED double | m_dAmount |
RDK_DEPRECATED ON_wString | m_sName |
Friends | |
class | CRhRdkBasicMaterial::CImpl |
Additional Inherited Members | |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
CRhRdkBasicMaterial::CTextureSlot::CTextureSlot | ( | const CTextureSlot & | slot | ) |
double CRhRdkBasicMaterial::CTextureSlot::Amount | ( | void | ) | const |
ON_wString CRhRdkBasicMaterial::CTextureSlot::ChildSlotName | ( | void | ) | const |
bool CRhRdkBasicMaterial::CTextureSlot::FilterOn | ( | void | ) | const |
ON_wString CRhRdkBasicMaterial::CTextureSlot::InternalName | ( | void | ) | const |
bool CRhRdkBasicMaterial::CTextureSlot::On | ( | void | ) | const |
bool CRhRdkBasicMaterial::CTextureSlot::operator!= | ( | const CTextureSlot & | slot | ) |
const CTextureSlot& CRhRdkBasicMaterial::CTextureSlot::operator= | ( | const CTextureSlot & | slot | ) |
bool CRhRdkBasicMaterial::CTextureSlot::operator== | ( | const CTextureSlot & | slot | ) |
void CRhRdkBasicMaterial::CTextureSlot::ReadParametersFromSection | ( | const IRhRdk_XMLSection & | section, |
CRhRdkContent::ReadParamsContext | context | ||
) |
void CRhRdkBasicMaterial::CTextureSlot::SetAmount | ( | double | d | ) |
void CRhRdkBasicMaterial::CTextureSlot::SetField | ( | CRhRdkTexturedContentField * | p | ) |
void CRhRdkBasicMaterial::CTextureSlot::SetFilterOn | ( | bool | b | ) |
void CRhRdkBasicMaterial::CTextureSlot::SetOn | ( | bool | b | ) |
void CRhRdkBasicMaterial::CTextureSlot::SetSimulation | ( | IRhRdk_XMLSection & | section | ) | const |
void CRhRdkBasicMaterial::CTextureSlot::WriteParametersToSection | ( | IRhRdk_XMLSection & | section, |
CRhRdkContent::WriteParamsContext | context | ||
) | const |
|
friend |
RDK_DEPRECATED bool CRhRdkBasicMaterial::CTextureSlot::m_bFilterOn |
RDK_DEPRECATED bool CRhRdkBasicMaterial::CTextureSlot::m_bOn |
RDK_DEPRECATED double CRhRdkBasicMaterial::CTextureSlot::m_dAmount |
RDK_DEPRECATED ON_wString CRhRdkBasicMaterial::CTextureSlot::m_sName |