Rhino C++ API
8.13
|
#include <RhRdkContentKindList.h>
Public Member Functions | |
CRhRdkContentKindList () | |
CRhRdkContentKindList (const CRhRdkContentKindList &) | |
CRhRdkContentKindList (CRhRdkContent::Kinds kind) | |
virtual | ~CRhRdkContentKindList () |
virtual void | Add (CRhRdkContent::Kinds kind) |
virtual void | AddAllKinds (void) |
virtual bool | Contains (CRhRdkContent::Kinds kind) const |
virtual int | Count (void) const |
const CRhRdkContentKindList & | operator= (const CRhRdkContentKindList &other) |
CRhRdkContent::Kinds | operator[] (int index) const |
virtual void | Remove (CRhRdkContent::Kinds kind) |
virtual bool | SetFromSemicolonDelimitedString (const wchar_t *wsz) |
virtual CRhRdkContent::Kinds | SingleKind (void) const |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Static Public Member Functions | |
static bool | IsSupportedKind (CRhRdkContent::Kinds kind) |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
This class is a collection of content kind designations.
Supported kinds are listed in "RhRdkContentKinds.h"
CRhRdkContentKindList::CRhRdkContentKindList | ( | ) |
Construct with no kinds.
CRhRdkContentKindList::CRhRdkContentKindList | ( | CRhRdkContent::Kinds | kind | ) |
Construct from a single content kind.
CRhRdkContentKindList::CRhRdkContentKindList | ( | const CRhRdkContentKindList & | ) |
Copy constructor.
|
virtual |
|
virtual |
Add a kind to the list.
|
virtual |
Add all kinds to the list.
|
virtual |
Query whether or not the collection contains a particular kind designation.
|
virtual |
|
static |
Query whether or not a content kind is supported by RDK.
const CRhRdkContentKindList& CRhRdkContentKindList::operator= | ( | const CRhRdkContentKindList & | other | ) |
CRhRdkContent::Kinds CRhRdkContentKindList::operator[] | ( | int | index | ) | const |
|
virtual |
Remove a kind from the list.
|
virtual |
Set from a semicolon-delimited string of kinds, e.g., L"material;texture".
|
virtual |